[ Сегодня идет свободное скачивание без начисления Download ]


Статистика раздачи
Нет
 
   
 
Top  
 
 
Mac OS X Tiger 10.4.1 to 10.4.3 userland update + Intel Extreme Graphics 2 kexts
Год выпуска: 2005
Версия: 10.4.3 userland + 10.4.1 kernel
Разработчик: OSx86 project
Платформа: Intel only (SSE2 supported)
Системные требования: Интегрированная видеокарта серии Intel Extreme Graphics 2 (830M/845G/852GM/855GM/865G), установленная Mac OS X 10.4.1.
Язык интерфейса: только английский
Таблэтка: Не требуется
MD5 Хэш: 1a2c754749c2699737b0139f3de6b9f3
Описание: Однажды понадобилось поработать в Xcode и нативном окружении не дома, а из имеющихся машинок был только древний ноутбук с графикой 855GM. Сидеть в VESA все-таки неудобно из-за тормозов и отсутствия специфичных ноутбучных разрешений. Путем гугления были найдены необходимые кексты для 10.4.1 (и только! По-другому никак) от Darwin/x86 8.0.1, установив которые я получил нативное разрешение (в моем случае это было 1280x768) и QE (Quartz Extreme, 2D-ускорение).
Далее, выяснилось, что 10.4.1 настолько безнадежно отстал (практически весь софт который можно найти на просторах Интернета требует 10.4.3 и выше), что в срочном порядке через e2k был выужен юзерленд-апдейт для 10.4.1, который привносит фреймворки из 10.4.3, некоторое обновленное ПО и exec-патч, который позволяет запускать 10.4.2+ бинарники (с т.н. Mach-O форматом). Учтите, что будут работать лишь некоторые 10.4.2+ приложения, но все же это крайне необходимое дополнение для раздачи Mac OS X 10.4.1, уже существующей на Рутрекере. Настоящая 10.4.3 требует фреш-установки, и по-другому не получится.
Доп. информация:

Порядок установки

В образе из раздачи вы найдете AppleIntel830.tar.bz2, его необходимо распаковать и при необходимости дополнить AppleIntel830.kext/Contents/Info.plist ID'шкой вашей Extreme Graphics 2-видеокарточки. Сейчас там прописана поддержка 855GM и 915GM. Затем нужно положить кексты в /System/Library/Extensions/, расставить на них пермишены и аттрибуты, удалить Extensions.mkext и Extensions.kextcache из /System/Library/Extensions и перезагрузиться с параметром -F. Наконец, загляните в System Profiler, вы должны увидеть ваше нативное разрешение и указание того, что Quartz Extreme включен. Если ничего не получилось, следует перепроверить свои действия и почитать данный топик. На некоторых карточках от драйвера требуется предварительное выделение памяти для видеоадаптера (чего данное решение не умеет), QE не видит требуемый объем видеопамяти (ок. 16 Мб) и не активируется. В этом случае, людям помогала схема, где нужно сделать перезагрузку в Mac OS X прямо из Windows с установленным видео-драйвером, у некоторых людей QE активировался сам по себе после двойной перезагрузки в Mac OS X (в первый раз в сейфмоде).
Далее распаковываем osxupdate.tar из образа в раздаче и устанавливаем osx86-update.pkg (желательно перед и после установки сделать Repair Disk Permissions), потребуется перезагрузка.
В конце концов, для того, чтобы обойти проблему с установкой приложений требующих 10.4.3 положите SystemVersion.plist, присутствующий на образе в /System/Library/CoreServices.

Описание компонентов раздачи

osxupdate.tar

This package contains updates for your 10.4.1 installation
This has only been tested on a SSE3 proc cpu.
Highlights:
1. tun/tap driver.
2. x86 Flash Plugin.
3. Updated Safari + Webkit
4. All new Frameworks w/ SIMD optimizations.
5. Quicktime 7.0.4 x86 complete.
6. 10.4.1 Kernel with 10.4.2 exec patch.
7. SDL FAT Frameworks.
8. Growl x86 Frameworks.
Run xbench CPU test to confirm it is working properly. You should have a 50-70% better score.

Maxxuss Exec-10.4.2 Patch v0.1

Apple has recently released Mac OS X 10.4.2 for the x86 platform (actually, it’s only provided to developers as a Developer Transistion Kit, DTK). One of the changes is that the 10.4.2 development tools now generate application binaries with new header information (Mach-O file header). This new header is incompatible with 10.4.1, i.e. on your 10.4.1 x86 system, you cannot run software which was compiled on and for 10.4.2.
This patch modifies the 10.4.1 kernel to adapt for these changes. This means, you should be able to run 10.4.2 software.
Please note, that new software which is built for 10.4.2 might require up-to-date versions of specific system files, e.g. frameworks or libraries. In this case, you would also need to update these files. The software I tested so far, however, do not require newer system files.
As a side note on the patched kernel: It also contains the v0.5c SSE3->SSE2 emulator and runtime patcher, so that you can run Rosetta and 10.4.2 software.

Скриншоты

[Цитировать]



Показать сообщения:    

Текущее время: 08-Дек 12:58

Часовой пояс: UTC + 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
Вы не можете прикреплять файлы к сообщениям
Вы не можете скачивать файлы

!ВНИМАНИЕ!
Сайт не предоставляет электронные версии произведений, а занимается лишь коллекционированием и каталогизацией ссылок, присылаемых и публикуемых на форуме нашими читателями. Если вы являетесь правообладателем какого-либо представленного материала и не желаете, чтобы ссылка на него находилась в нашем каталоге, свяжитесь с нами, и мы незамедлительно удалим ее. Файлы для обмена на трекере предоставлены пользователями сайта, и администрация не несет ответственности за их содержание. Просьба не заливать файлы, защищенные авторскими правами, а также файлы нелегального содержания!